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1 实验指导书

实验是课程配套的，主页在https://gaia.cs.umass.edu/kurose_ross/wireshark.php．我
们采用的是第 7 版，有一些地方（IP，TLS 等）不如最新版本详尽．同学们可以自行查阅最新的 8.1
版本进行补充，或者遇到问题时询问我们．

2 实验的一些小 tip

1. 实验需要关闭代理，因为你们的代理服务器一般是在某个本地端口监听的（7890 懂的都懂），
所以抓取网络设备流量时，只会抓到代理程序和 VPS 程序间的加密/混淆通信．

2. 部分实验为确保 200 OK 需要使用浏览器的缓存配置．一般在 F12 呼出的调试菜单中有．

3. 部分实验使用了国外的 DNS，可能会受到干扰影响实验结果．为方便同学进行实验，同学们
可使用科大 DNS 或者其他公共 DNS 替换．

3 Wireshark 过滤器语法

使用 Wireshark 最重要的就是学会他的两套过滤器语法了，使用合适的过滤器可以让你在实验
中事半功倍：

• Display Filter（实验用的）

• Capture Filter（同 BPF，tcpdump 语法）

其中，Display Filter 是实验中重点使用的，相较于 Capture Filter 有很多语法糖，作用是对已
经捕获的包进行过滤．文档参看1．

Capture Filter 是原始的 BPF 语法，在进行抓包之前可以指定，可以让不必要的包不被捕获．
文档参看2．

1https://www.wireshark.org/docs/wsug_html_chunked/ChWorkBuildDisplayFilterSection.html
2https://www.wireshark.org/docs/wsug_html_chunked/ChCapCaptureFilterSection.html
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图 1: Wireshark 的主界面，上方的紫色框中可以填写 Display Filter，中间的橙色框中可以填写
Capture Filter．

举个例子，若想过滤出 TCP 的目标端口号为 80 的包，两种过滤器的对应语法为：
Display Filter Capture Filter
tcp.dstport == 80 tcp dst port 80

4 IPv6 相关问题

目前，在各种网络环境中，都有可能实际使用的是 IPv6 而不是更古早的 IPv4．然而第七版的
实验指导书里仍然使用 IPv4 作为例子和指南．这是落后时代的．在最新的实验指导书中已经为此
进行了补充3，但是仍然不够充足．

下面是遇到 IPv6 相关问题的两个解决方案：

1. 关闭 IPv6 协议栈，回退到 IPv4：最新版指导书中的一种做法（可自行查阅对应系统的关闭方
法）

2. 学会怎么使用 IPv6 体系（麻，按照 top-down 的进度还没学到网络层）
这里简单列一下可能需要会用上的 tip：

• IPv6 全长 128bit，以 16bit 为一组，每组以冒号“:”隔开，分为 8 组．如果遇到全为零
的组可以跳过进行简写，产生一个“::”，简写只可以发生一次，也就是只能有一个“::”
2001:0db8:0000:0000:0000:0000:0000:0001 可以写作 2001:db8::1．4

• 域名的 IPv6 地址查询：nslookup -type=AAAA www.ustc.edu.cn
3在 DNS 实验补充了一句话（关掉 IPv6 协议栈），在 IP 实验中补充了一节
4更多参见https://zh.wikipedia.org/wiki/IPv6
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• 在 Wireshark 已捕获的包中过滤 IPv6 相关包需要的语法和对应关系
ipv6.src ipv6.dst ipv6.addr

ip.src ip.dst ip.addr
你们可以用类似 ipv6.src == 2001:db8::1 的语法来过滤相应的包．
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One’s understanding of network protocols can often be greatly deepened by “seeing 
protocols in action” and by “playing around with protocols” – observing the sequence of 
messages exchanged between two protocol entities, delving down into the details of 
protocol operation, and causing protocols to perform certain actions and then observing 
these actions and their consequences. This can be done in simulated scenarios or in a 
“real” network environment such as the Internet. In the Wireshark labs you’ll be doing in 
this course, you’ll be running various network applications in different scenarios using 
your own computer (or you can borrow a friends; let me know if you don’t have access to 
a computer where you can install/run Wireshark). You’ll observe the network protocols 
in your computer “in action,” interacting and exchanging messages with protocol entities 
executing elsewhere in the Internet.   Thus, you and your computer will be an integral 
part of these “live” labs.  You’ll observe, and you’ll learn, by doing. 
 
In this first Wireshark lab, you’ll get acquainted with Wireshark, and make some simple 
packet captures and observations. 
 
The basic tool for observing the messages exchanged between executing protocol entities 
is called a packet sniffer.  As the name suggests, a packet sniffer captures (“sniffs”) 
messages being sent/received from/by your computer; it will also typically store and/or 
display the contents of the various protocol fields in these captured messages. A packet 
sniffer itself is passive. It observes messages being sent and received by applications and 
protocols running on your computer, but never sends packets itself. Similarly, received 
packets are never explicitly addressed to the packet sniffer.  Instead, a packet sniffer 
receives a copy of packets that are sent/received from/by application and protocols 
executing on your machine. 
 
Figure 1 shows the structure of a packet sniffer. At the right of Figure 1 are the protocols 
(in this case, Internet protocols) and applications (such as a web browser or ftp client) 
that normally run on your computer.  The packet sniffer, shown within the dashed 
rectangle in Figure 1 is an addition to the usual software in your computer, and consists 



of two parts.  The packet capture library receives a copy of every link-layer frame that 
is sent from or received by your computer.  Recall from the discussion from section 1.5 in 
the text (Figure 1.241) that messages exchanged by higher layer protocols such as HTTP, 
FTP, TCP, UDP, DNS, or IP all are eventually encapsulated in link-layer frames that are 
transmitted over physical media such as an Ethernet cable.  In Figure 1, the assumed 
physical media is an Ethernet, and so all upper-layer protocols are eventually 
encapsulated within an Ethernet frame.  Capturing all link-layer frames thus gives you all 
messages sent/received from/by all protocols and applications executing in your 
computer. 
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Figure 1: Packet sniffer structure 
to/from network to/from network 

 
 
The second component of a packet sniffer is the packet analyzer, which displays the 
contents of all fields within a protocol message.  In order to do so, the packet analyzer 
must “understand” the structure of all messages exchanged by protocols.  For example, 
suppose we are interested in displaying the various fields in messages exchanged by the 
HTTP protocol in Figure 1. The packet analyzer understands the format of Ethernet 
frames, and so can identify the IP datagram within an Ethernet frame.  It also understands 
the IP datagram format, so that it can extract the TCP segment within the IP datagram.  
Finally, it understands the TCP segment structure, so it can extract the HTTP message 
contained in the TCP segment.  Finally, it understands the HTTP protocol and so, for 
example, knows that the first bytes of an HTTP message will contain the string “GET,” 
“POST,” or “HEAD,” as shown in Figure 2.8 in the text. 

We will be using the Wireshark packet sniffer [http://www.wireshark.org/] for these labs, 
allowing us to display the contents of messages being sent/received from/by protocols at 
different levels of the protocol stack.  (Technically speaking, Wireshark is a packet 
analyzer that uses a packet capture library in your computer). Wireshark is a free network 
protocol analyzer that runs on Windows, Mac, and Linux/Unix computer. It’s an ideal 
packet analyzer for our labs – it is stable, has a large user base and well-documented 
support that includes a user-guide (http://www.wireshark.org/docs/wsug_html_chunked/), 
                                                
1 References to figures and sections are for the 7th edition of our text, Computer Networks, A Top-down 
Approach, 7th ed., J.F. Kurose and K.W. Ross, Addison-Wesley/Pearson, 2016. 



man pages (http://www.wireshark.org/docs/man-pages/), and a detailed FAQ 
(http://www.wireshark.org/faq.html), rich functionality that includes the capability to 
analyze hundreds of protocols, and a well-designed user interface. It operates in 
computers using Ethernet, serial (PPP and SLIP), 802.11 wireless LANs, and many other 
link-layer technologies (if the OS on which it's running allows Wireshark to do so). 

 
Getting Wireshark 
 
In order to run Wireshark, you will need to have access to a computer that supports both 
Wireshark and the libpcap or WinPCap packet capture library. The libpcap software will 
be installed for you, if it is not installed within your operating system, when you install 
Wireshark.  See http://www.wireshark.org/download.html for a list of supported 
operating systems and download sites 
 
Download and install the Wireshark software: 

• Go to http://www.wireshark.org/download.html and download and install the 
Wireshark binary for your computer.  

The Wireshark FAQ has a number of helpful hints and interesting tidbits of information, 
particularly if you have trouble installing or running Wireshark. 
 
Running Wireshark 
 
When you run the Wireshark program, you’ll get a startup screen that looks something 
like the screen below.  Different versions of Wireshark will have different startup screens 
– so don’t panic if yours doesn’t look exactly like the screen below!  The Wireshark 
documentation states “As Wireshark runs on many different platforms with many 
different window managers, different styles applied and there are different versions of the 
underlying GUI toolkit used, your screen might look different from the provided 
screenshots. But as there are no real differences in functionality these screenshots should 
still be well understandable.”  Well said. 
 



 
Figure 2: Initial Wireshark Screen 

 
There’s not much interesting on this screen.  But note that under the Capture section, 
there is a list of so-called interfaces.  The computer we’re taking these screenshots from 
has just one real interface – “Wi-Fi en0,” which is the interface for Wi-Fi access.  All 
packets to/from this computer will pass through the Wi-Fi interface, so it’s here where we 
want to capture packets.  On a Mac, double click on this interface (or on another 
computer locate the interface on startup page through which you are getting Internet 
connectivity, e.g., mostly likely a WiFi or Ethernet interface, and select that interface. 
 
Let’s take Wireshark out for a spin! If you click on one of these interfaces to start packet 
capture (i.e., for Wireshark to begin capturing all packets being sent to/from that 
interface), a screen like the one below will be displayed, showing information about the 
packets being captured.  Once you start packet capture, you can stop it by using the 
Capture pull down menu and selecting Stop. 
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Figure 3: Wireshark Graphical User Interface, during packet capture and analysis 

 
This looks more interesting! The Wireshark interface has five major components: 

• The command menus are standard pulldown menus located at the top of the 
window.  Of interest to us now are the File and Capture menus.  The File menu 
allows you to save captured packet data or open a file containing previously 
captured packet data, and exit the Wireshark application.  The Capture menu 
allows you to begin packet capture. 



• The packet-listing window displays a one-line summary for each packet 
captured, including the packet number (assigned by Wireshark; this is not a 
packet number contained in any protocol’s header), the time at which the packet 
was captured, the packet’s source and destination addresses, the protocol type, 
and protocol-specific information contained in the packet. The packet listing can 
be sorted according to any of these categories by clicking on a column name.  The 
protocol type field lists the highest-level protocol that sent or received this packet, 
i.e., the protocol that is the source or ultimate sink for this packet. 

• The packet-header details window provides details about the packet selected 
(highlighted) in the packet-listing window.  (To select a packet in the packet-
listing window, place the cursor over the packet’s one-line summary in the 
packet-listing window and click with the left mouse button.).  These details 
include information about the Ethernet frame (assuming the packet was 
sent/received over an Ethernet interface) and IP datagram that contains this 
packet. The amount of Ethernet and IP-layer detail displayed can be expanded or 
minimized by clicking on the plus minus boxes to the left of the Ethernet frame or 
IP datagram line in the packet details window.  If the packet has been carried over 
TCP or UDP, TCP or UDP details will also be displayed, which can similarly be 
expanded or minimized.  Finally, details about the highest-level protocol that sent 
or received this packet are also provided. 

• The packet-contents window displays the entire contents of the captured frame, 
in both ASCII and hexadecimal format. 

• Towards the top of the Wireshark graphical user interface, is the packet display 
filter field, into which a protocol name or other information can be entered in 
order to filter the information displayed in the packet-listing window (and hence 
the packet-header and packet-contents windows).  In the example below, we’ll 
use the packet-display filter field to have Wireshark hide (not display) packets 
except those that correspond to HTTP messages. 

 
Taking Wireshark for a Test Run 
 
The best way to learn about any new piece of software is to try it out!  We’ll assume that 
your computer is connected to the Internet via a wired Ethernet interface. Indeed, I 
recommend that you do this first lab on a computer that has a wired Ethernet connection, 
rather than just a wireless connection. Do the following 
 

1. Start up your favorite web browser, which will display your selected homepage. 
 
2. Start up the Wireshark software.  You will initially see a window similar to that 

shown in Figure 2. Wireshark has not yet begun capturing packets. 
 
3. To begin packet capture, select the Capture pull down menu and select Interfaces. 

This will cause the “Wireshark: Capture Interfaces” window to be displayed, as 
shown in Figure 4. 

 



 Figure 4: Wireshark Capture Interface Window 
 

4. You’ll see a list of the interfaces on your computer as well as a count of the 
packets that have been observed on that interface so far.  Click on Start for the 
interface on which you want to begin packet capture (in the case, the Gigabit 
network Connection).  Packet capture will now begin - Wireshark is now 
capturing all packets being sent/received from/by your computer! 

 
5. Once you begin packet capture, a window similar to that shown in Figure 3 will 

appear.  This window shows the packets being captured.  By selecting Capture 
pulldown menu and selecting Stop, you can stop packet capture.   But don’t stop 
packet capture yet.  Let’s capture some interesting packets first.  To do so, we’ll 
need to generate some network traffic.  Let’s do so using a web browser, which 
will use the HTTP protocol that we will study in detail in class to download 
content from a website. 

 
 

6. While Wireshark is running, enter the URL:  
http://gaia.cs.umass.edu/wireshark-labs/INTRO-wireshark-file1.html 
and have that page displayed in your browser. In order to display this page, your 
browser will contact the HTTP server at gaia.cs.umass.edu and exchange HTTP 
messages with the server in order to download this page, as discussed in section 
2.2 of the text.  The Ethernet frames containing these HTTP messages (as well as 
all other frames passing through your Ethernet adapter) will be captured by 
Wireshark. 

 
7. After your browser has displayed the INTRO-wireshark-file1.html page (it is a 

simple one line of congratulations), stop Wireshark packet capture by selecting 
stop in the Wireshark capture window.   The main Wireshark window should now 
look similar to Figure 3. You now have live packet data that contains all protocol 
messages exchanged between your computer and other network entities!  The 
HTTP message exchanges with the gaia.cs.umass.edu web server should appear 
somewhere in the listing of packets captured.  But there will be many other types 
of packets displayed as well (see, e.g., the many different protocol types shown in 
the Protocol column in Figure 3).  Even though the only action you took was to 
download a web page, there were evidently many other protocols running on your 
computer that are unseen by the user.  We’ll learn much more about these 
protocols as we progress through the text!  For now, you should just be aware that 
there is often much more going on than “meet’s the eye”! 



 
8. Type in “http” (without the quotes, and in lower case – all protocol names are in 

lower case in Wireshark) into the display filter specification window at the top of 
the main Wireshark window.  Then select Apply (to the right of where you entered 
“http”).  This will cause only HTTP message to be displayed in the packet-listing 
window.   

 
9. Find the HTTP GET message that was sent from your computer to the 

gaia.cs.umass.edu HTTP server. (Look for an HTTP GET message in the “listing 
of captured packets” portion of the Wireshark window (see Figure 3) that shows 
“GET” followed by the gaia.cs.umass.edu URL that you entered.  When you 
select the HTTP GET message, the Ethernet frame, IP datagram, TCP segment, 
and HTTP message header information will be displayed in the packet-header 
window2. By clicking on ‘+’ and ‘-‘ right-pointing and down-pointing arrowheads 
to the left side of the packet details window, minimize the amount of Frame, 
Ethernet, Internet Protocol, and Transmission Control Protocol information 
displayed.  Maximize the amount information displayed about the HTTP protocol.  
Your Wireshark display should now look roughly as shown in Figure 5. (Note, in 
particular, the minimized amount of protocol information for all protocols except 
HTTP, and the maximized amount of protocol information for HTTP in the 
packet-header window). 

 
10. Exit Wireshark 

 
Congratulations!  You’ve now completed the first lab. 
 

                                                
2 Recall that the HTTP GET message that is sent to the gaia.cs.umass.edu web server is contained within a 
TCP segment, which is contained (encapsulated) in an IP datagram, which is encapsulated in an Ethernet 
frame.  If this process of encapsulation isn’t quite clear yet, review section 1.5 in the text 



 
Figure 5: Wireshark window after step 9 



What to hand in 
 
The goal of this first lab was primarily to introduce you to Wireshark. The following 
questions will demonstrate that you’ve been able to get Wireshark up and running, and 
have explored some of its capabilities. Answer the following questions, based on your 
Wireshark experimentation: 
 

1. List 3 different protocols that appear in the protocol column in the unfiltered 
packet-listing window in step 7 above.   

2. How long did it take from when the HTTP GET message was sent until the HTTP 
OK reply was received? (By default, the value of the Time column in the packet-
listing window is the amount of time, in seconds, since Wireshark tracing began.  
To display the Time field in time-of-day format, select the Wireshark View pull 
down menu, then select Time Display Format, then select Time-of-day.) 

3. What is the Internet address of the gaia.cs.umass.edu (also known as www-
net.cs.umass.edu)?  What is the Internet address of your computer? 

4. Print the two HTTP messages (GET and OK) referred to in question 2 above. To 
do so, select Print from the Wireshark File command menu, and select the 
“Selected Packet Only” and “Print as displayed” radial buttons, and then click 
OK. 
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Having gotten our feet wet with the Wireshark packet sniffer in the introductory lab, 
we’re now ready to use Wireshark to investigate protocols in operation. In this lab, we’ll 
explore several aspects of the HTTP protocol: the basic GET/response interaction, HTTP 
message formats, retrieving large HTML files, retrieving HTML files with embedded 
objects, and HTTP authentication and security. Before beginning these labs, you might 
want to review Section 2.2 of the text.1 
 
1. The Basic HTTP GET/response interaction 
 
Let’s begin our exploration of HTTP by downloading a very simple HTML file - one that 
is very short, and contains no embedded objects.  Do the following: 

1. Start up your web browser. 
2. Start up the Wireshark packet sniffer, as described in the Introductory lab (but 

don’t yet begin packet capture).  Enter “http” (just the letters, not the quotation 
marks) in the display-filter-specification window, so that only captured HTTP 
messages will be displayed later in the packet-listing window.  (We’re only 
interested in the HTTP protocol here, and don’t want to see the clutter of all 
captured packets).    

3. Wait a bit more than one minute (we’ll see why shortly), and then begin 
Wireshark packet capture. 

4. Enter the following to your browser 
http://gaia.cs.umass.edu/wireshark-labs/HTTP-wireshark-file1.html 
Your browser should display the very simple, one-line HTML file. 

5. Stop Wireshark packet capture. 
 

                                                
1 References to figures and sections are for the 7th edition of our text, Computer Networks, A Top-down 
Approach, 7th ed., J.F. Kurose and K.W. Ross, Addison-Wesley/Pearson, 2016. 



Your Wireshark window should look similar to the window shown in Figure 1.  If you 
are unable to run Wireshark on a live network connection, you can download a packet 
trace that was created when the steps above were followed.2 
 

 
 

Figure 1: Wireshark Display after http://gaia.cs.umass.edu/wireshark-labs/ HTTP-
wireshark-file1.html has been retrieved by your browser 

 
The example in Figure 1 shows in the packet-listing window that two HTTP messages 
were captured: the GET message (from your browser to the gaia.cs.umass.edu web 
server) and the response message from the server to your browser.  The packet-contents 
window shows details of the selected message (in this case the HTTP OK message, 
which is highlighted in the packet-listing window).  Recall that since the HTTP message 
was carried inside a TCP segment, which was carried inside an IP datagram, which was 
carried within an Ethernet frame, Wireshark displays the Frame, Ethernet, IP, and TCP 
packet information as well.  We want to minimize the amount of non-HTTP data 
displayed (we’re interested in HTTP here, and will be investigating these other protocols 
is later labs), so make sure the boxes at the far left of the Frame, Ethernet, IP and TCP 
information have a plus sign or a right-pointing triangle (which means there is hidden, 
undisplayed information), and the HTTP line has a minus sign or a down-pointing 
triangle (which means that all information about the HTTP message is displayed). 
                                                
2  Download the zip file http://gaia.cs.umass.edu/wireshark-labs/wireshark-traces.zip and extract the file 
http-ethereal-trace-1. The traces in this zip file were collected by Wireshark running on one of the author’s 
computers, while performing the steps indicated in the Wireshark lab. Once you have downloaded the 
trace, you can load it into Wireshark and view the trace using the File pull down menu, choosing Open, and 
then selecting the http-ethereal-trace-1 trace file.  The resulting display should look similar to Figure 1. 
(The Wireshark user interface displays just a bit differently on different operating systems, and in different 
versions of Wireshark). 



 
(Note: You should ignore any HTTP GET and response for favicon.ico.  If you see a reference to 
this file, it is your browser automatically asking the server if it (the server) has a small icon file 
that should be displayed next to the displayed URL in your browser.  We’ll ignore references to 
this pesky file in this lab.). 

 
By looking at the information in the HTTP GET and response messages, answer the 
following questions.  When answering the following questions, you should print out the 
GET and response messages (see the introductory Wireshark lab for an explanation of 
how to do this) and indicate where in the message you’ve found the information that 
answers the following questions. When you hand in your assignment, annotate the output 
so that it’s clear where in the output you’re getting the information for your answer (e.g., 
for our classes, we ask that students markup paper copies with a pen, or annotate 
electronic copies with text in a colored font). 

1. Is your browser running HTTP version 1.0 or 1.1?  What version of HTTP is the 
server running? 

2. What languages (if any) does your browser indicate that it can accept to the 
server? 

3. What is the IP address of your computer?  Of the gaia.cs.umass.edu server? 
4. What is the status code returned from the server to your browser? 
5. When was the HTML file that you are retrieving last modified at the server? 
6. How many bytes of content are being returned to your browser? 
7. By inspecting the raw data in the packet content window, do you see any headers 

within the data that are not displayed in the packet-listing window?  If so, name 
one. 

 
In your answer to question 5 above, you might have been surprised to find that the 
document you just retrieved was last modified within a minute before you downloaded 
the document. That’s because (for this particular file), the gaia.cs.umass.edu server is 
setting the file’s last-modified time to be the current time, and is doing so once per 
minute. Thus, if you wait a minute between accesses, the file will appear to have been 
recently modified, and hence your browser will download a “new” copy of the document. 
 
2. The HTTP CONDITIONAL GET/response interaction 
 
Recall from Section 2.2.5 of the text, that most web browsers perform object caching and 
thus perform a conditional GET when retrieving an HTTP object. Before performing the 
steps below, make sure your browser’s cache is empty. (To do this under Firefox, select 
Tools->Clear Recent History and check the Cache box, or for Internet Explorer, select 
Tools->Internet Options->Delete File; these actions will remove cached files from your 
browser’s cache.) Now do the following: 

• Start up your web browser, and make sure your browser’s cache is cleared, as 
discussed above. 

• Start up the Wireshark packet sniffer 
• Enter the following URL into your browser 

http://gaia.cs.umass.edu/wireshark-labs/HTTP-wireshark-file2.html 
Your browser should display a very simple five-line HTML file.  



• Quickly enter the same URL into your browser again (or simply select the refresh 
button on your browser) 

• Stop Wireshark packet capture, and enter “http” in the display-filter-specification 
window, so that only captured HTTP messages will be displayed later in the 
packet-listing window.   

• (Note:  If you are unable to run Wireshark on a live network connection, you can 
use the http-ethereal-trace-2 packet trace to answer the questions below; see 
footnote 1. This trace file was gathered while performing the steps above on one 
of the author’s computers.)  

 
Answer the following questions: 

8. Inspect the contents of the first HTTP GET request from your browser to the 
server.  Do you see an “IF-MODIFIED-SINCE” line in the HTTP GET? 

9. Inspect the contents of the server response. Did the server explicitly return the 
contents of the file?   How can you tell? 

10. Now inspect the contents of the second HTTP GET request from your browser to 
the server.  Do you see an “IF-MODIFIED-SINCE:” line in the HTTP GET? If 
so, what information follows the “IF-MODIFIED-SINCE:” header? 

11. What is the HTTP status code and phrase returned from the server in response to 
this second HTTP GET?  Did the server explicitly return the contents of the file?   
Explain. 

 
 
3. Retrieving Long Documents 
 
In our examples thus far, the documents retrieved have been simple and short HTML 
files. Let’s next see what happens when we download a long HTML file.  Do the 
following: 

• Start up your web browser, and make sure your browser’s cache is cleared, as 
discussed above. 

• Start up the Wireshark packet sniffer 
• Enter the following URL into your browser 

http://gaia.cs.umass.edu/wireshark-labs/HTTP-wireshark-file3.html 
Your browser should display the rather lengthy US Bill of Rights. 

• Stop Wireshark packet capture, and enter “http” in the display-filter-specification 
window, so that only captured HTTP messages will be displayed.  

• (Note:  If you are unable to run Wireshark on a live network connection, you can 
use the http-ethereal-trace-3 packet trace to answer the questions below; see 
footnote 1. This trace file was gathered while performing the steps above on one 
of the author’s computers.)  

 
In the packet-listing window, you should see your HTTP GET message, followed by a 
multiple-packet TCP response to your HTTP GET request.  This multiple-packet 
response deserves a bit of explanation.  Recall from Section 2.2 (see Figure 2.9 in the 
text) that the HTTP response message consists of a status line, followed by header lines, 
followed by a blank line, followed by the entity body.  In the case of our HTTP GET, the 



entity body in the response is the entire requested HTML file.  In our case here, the 
HTML file is rather long, and at 4500 bytes is too large to fit in one TCP packet.  The 
single HTTP response message is thus broken into several pieces by TCP, with each 
piece being contained within a separate TCP segment (see Figure 1.24 in the text). In 
recent versions of Wireshark, Wireshark indicates each TCP segment as a separate 
packet, and the fact that the single HTTP response was fragmented across multiple TCP 
packets is indicated by the “TCP segment of a reassembled PDU” in the Info column of 
the Wireshark display.  Earlier versions of Wireshark used  the “Continuation” phrase to 
indicated that the entire content of an HTTP message was broken across multiple TCP 
segments..  We stress here that there is no “Continuation” message in HTTP! 
 
Answer the following questions: 

12. How many HTTP GET request messages did your browser send?  Which packet 
number in the trace contains the GET message for the Bill or Rights? 

13. Which packet number in the trace contains the status code and phrase associated 
with the response to the HTTP GET request? 

14. What is the status code and phrase in the response? 
15. How many data-containing TCP segments were needed to carry the single HTTP 

response and the text of the Bill of Rights? 
 
 
4. HTML Documents with Embedded Objects 
 
Now that we’ve seen how Wireshark displays the captured packet traffic for large HTML 
files, we can look at what happens when your browser downloads a file with embedded 
objects, i.e., a file that includes other objects (in the example below, image files) that are 
stored on another server(s). 
 
Do the following: 

• Start up your web browser, and make sure your browser’s cache is cleared, as 
discussed above. 

• Start up the Wireshark packet sniffer 
• Enter the following URL into your browser 

http://gaia.cs.umass.edu/wireshark-labs/HTTP-wireshark-file4.html 
Your browser should display a short HTML file with two images. These two 
images are referenced in the base HTML file.  That is, the images themselves are 
not contained in the HTML; instead the URLs for the images are contained in the 
downloaded HTML file. As discussed in the textbook, your browser will have to 
retrieve these logos from the indicated web sites.   Our publisher’s logo is 
retrieved from the gaia.cs.umass.edu web site.  The image of the cover for our 5th 
edition (one of our favorite covers) is stored at the caite.cs.umass.edu server. 
(These are two different web servers inside cs.umass.edu). 

• Stop Wireshark packet capture, and enter “http” in the display-filter-specification 
window, so that only captured HTTP messages will be displayed.  



• (Note:  If you are unable to run Wireshark on a live network connection, you can 
use the http-ethereal-trace-4 packet trace to answer the questions below; see 
footnote 1. This trace file was gathered while performing the steps above on one 
of the author’s computers.)  

 
Answer the following questions: 

16. How many HTTP GET request messages did your browser send?  To which 
Internet addresses were these GET requests sent? 

17. Can you tell whether your browser downloaded the two images serially, or 
whether they were downloaded from the two web sites in parallel?  Explain. 

 
5 HTTP Authentication 
 
Finally, let’s try visiting a web site that is password-protected and examine the sequence 
of HTTP message exchanged for such a site.  The URL  
http://gaia.cs.umass.edu/wireshark-labs/protected_pages/HTTP-wireshark-file5.html is 
password protected.  The username is “wireshark-students” (without the quotes), and the 
password is “network” (again, without the quotes).  So let’s access this “secure” 
password-protected site.  Do the following: 

• Make sure your browser’s cache is cleared, as discussed above, and close down 
your browser.  Then, start up your browser 

• Start up the Wireshark packet sniffer 
• Enter the following URL into your browser 

http://gaia.cs.umass.edu/wireshark-labs/protected_pages/HTTP-wireshark-
file5.html 
Type the requested user name and password into the pop up box. 

• Stop Wireshark packet capture, and enter “http” in the display-filter-specification 
window, so that only captured HTTP messages will be displayed later in the 
packet-listing window.   

• (Note:  If you are unable to run Wireshark on a live network connection, you can 
use the http-ethereal-trace-5 packet trace to answer the questions below; see 
footnote 2. This trace file was gathered while performing the steps above on one 
of the author’s computers.)  

Now let’s examine the Wireshark output.  You might want to first read up on HTTP 
authentication by reviewing the easy-to-read material on “HTTP Access Authentication 
Framework” at http://frontier.userland.com/stories/storyReader$2159 

Answer the following questions: 
18. What is the server’s response (status code and phrase) in response to the initial 

HTTP GET message from your browser? 
19. When your browser’s sends the HTTP GET message for the second time, what 

new field is included in the HTTP GET message? 
 
The username (wireshark-students) and password (network) that you entered are encoded 
in the string of characters (d2lyZXNoYXJrLXN0dWRlbnRzOm5ldHdvcms=) following 



the “Authorization: Basic” header in the client’s HTTP GET message.  While it 
may appear that your username and password are encrypted, they are simply encoded in a 
format known as Base64 format. The username and password are not encrypted!  To see 
this, go to  http://www.motobit.com/util/base64-decoder-encoder.asp and enter the 
base64-encoded string d2lyZXNoYXJrLXN0dWRlbnRz and decode.  Voila!  You have 
translated from Base64 encoding to ASCII encoding, and thus should see your username!  
To view the password, enter the remainder of the string Om5ldHdvcms= and press 
decode.  Since anyone can download a tool like Wireshark and sniff packets (not just 
their own) passing by their network adaptor, and anyone can translate from Base64 to 
ASCII (you just did it!), it should be clear to you that simple passwords on WWW sites 
are not secure unless additional measures are taken. 
 
Fear not! As we will see in Chapter 8, there are ways to make WWW access more secure.  
However, we’ll clearly need something that goes beyond the basic HTTP authentication 
framework! 
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As described in Section 2.4 of the text1, the Domain Name System (DNS) translates 
hostnames to IP addresses, fulfilling a critical role in the Internet infrastructure. In this 
lab, we’ll take a closer look at the client side of DNS. Recall that the client’s role in the 
DNS is relatively simple – a client sends a query to its local DNS server, and receives a 
response back.  As shown in Figures 2.19 and 2.20 in the textbook, much can go on 
“under the covers,” invisible to the DNS clients, as the hierarchical DNS servers 
communicate with each other to either recursively or iteratively resolve the client’s DNS 
query.  From the DNS client’s standpoint, however, the protocol is quite simple – a query 
is formulated to the local DNS server and a response is received from that server. 
 
Before beginning this lab, you’ll probably want to review DNS by reading Section 2.4 of 
the text.  In particular, you may want to review the material on local DNS servers, DNS 
caching, DNS records and messages, and the TYPE field in the DNS record.  
 
 
1. nslookup 
 
In this lab, we’ll make extensive use of the nslookup tool, which is available in most 
Linux/Unix and Microsoft platforms today. To run nslookup in Linux/Unix, you just type 
the nslookup command on the command line. To run it in Windows, open the Command 
Prompt and run nslookup on the command line.  
 
In it is most basic operation, nslookup tool allows the host running the tool to query any 
specified DNS server for a DNS record. The queried DNS server can be a root DNS 
server, a top-level-domain DNS server, an authoritative DNS server, or an intermediate 
DNS server (see the textbook for definitions of these terms). To accomplish this task, 
nslookup sends a DNS query to the specified DNS server, receives a DNS reply from that 
same DNS server, and displays the result.  

                                                
1 References to figures and sections are for the 7th edition of our text, Computer Networks, A Top-down 
Approach, 7th ed., J.F. Kurose and K.W. Ross, Addison-Wesley/Pearson, 2016. 



 
 

 
 
The above screenshot shows the results of three independent nslookup commands 
(displayed in the Windows Command Prompt). In this example, the client host is located 
on the campus of Polytechnic University in Brooklyn, where the default local DNS server 
is dns-prime.poly.edu. When running nslookup, if no DNS server is specified, then 
nslookup sends the query to the default DNS server, which in this case is dns-
prime.poly.edu. Consider the first command: 
 
nslookup www.mit.edu 
 
In words, this command is saying “please send me the IP address for the host 
www.mit.edu”. As shown in the screenshot, the response from this command provides 
two pieces of information: (1) the name and IP address of the DNS server that provides 
the answer; and (2) the answer itself, which is the host name and IP address of 
www.mit.edu. Although the response came from the local DNS server at Polytechnic 
University, it is quite possible that this local DNS server iteratively contacted several 
other DNS servers to get the answer, as described in Section 2.4 of the textbook.  
 
Now consider the second command: 
 
nslookup –type=NS mit.edu 
 
In this example, we have provided the option “-type=NS” and the domain “mit.edu”. This 
causes nslookup to send a query for a type-NS record to the default local DNS server. In 



words, the query is saying, “please send me the host names of the authoritative DNS for 
mit.edu”. (When the –type option is not used, nslookup uses the default, which is to query 
for type A records.) The answer, displayed in the above screenshot, first indicates the 
DNS server that is providing the answer (which is the default local DNS server) along 
with three MIT nameservers. Each of these servers is indeed an authoritative DNS server 
for the hosts on the MIT campus. However, nslookup also indicates that the answer is 
“non-authoritative,” meaning that this answer came from the cache of some server rather 
than from an authoritative MIT DNS server. Finally, the answer also includes the IP 
addresses of the authoritative DNS servers at MIT. (Even though the type-NS query 
generated by nslookup did not explicitly ask for the IP addresses, the local DNS server 
returned these “for free” and nslookup displays the result.) 
 
Now finally consider the third command: 
 
nslookup www.aiit.or.kr bitsy.mit.edu 
 
In this example, we indicate that we want to the query sent to the DNS server 
bitsy.mit.edu rather than to the default DNS server (dns-prime.poly.edu). Thus, the query 
and reply transaction takes place directly between our querying host and bitsy.mit.edu. In 
this example, the DNS server bitsy.mit.edu provides the IP address of the host 
www.aiit.or.kr, which is a web server at the Advanced Institute of Information 
Technology (in Korea).  
 
Now that we have gone through a few illustrative examples, you are perhaps wondering 
about the general syntax of nslookup commands. The syntax is: 
 
nslookup –option1 –option2 host-to-find dns-server 
 
In general, nslookup can be run with zero, one, two or more options. And as we have seen 
in the above examples, the dns-server is optional as well; if it is not supplied, the query is 
sent to the default local DNS server.  
 
Now that we have provided an overview of nslookup, it is time for you to test drive it 
yourself. Do the following (and write down the results): 
 

1. Run nslookup to obtain the IP address of a Web server in Asia. What is the IP 
address of that server? 

2. Run nslookup to determine the authoritative DNS servers for a university in 
Europe. 

3. Run nslookup so that one of the DNS servers obtained in Question 2 is queried for 
the mail servers for Yahoo! mail.   What is its IP address? 

 
2. ipconfig 
 
ipconfig (for Windows) and ifconfig (for Linux/Unix) are among the most useful little 
utilities in your host, especially for debugging network issues. Here we’ll only describe 



ipconfig, although the Linux/Unix ifconfig is very similar. ipconfig can be used to show 
your current TCP/IP information, including your address, DNS server addresses, adapter 
type and so on. For example, if you all this information about your host simply by 
entering  
 
ipconfig \all 
 
into the Command Prompt, as shown in the following screenshot. 
 
 

 
 
 
ipconfig is also very useful for managing the DNS information stored in your host. In 
Section 2.5 we learned that a host can cache DNS records it recently obtained. To see 
these cached records, after the prompt C:\> provide the following command: 
 
ipconfig /displaydns 

Each entry shows the remaining Time to Live (TTL) in seconds. To clear the cache, enter 

ipconfig /flushdns 

Flushing the DNS cache clears all entries and reloads the entries from the hosts file. 



3. Tracing DNS with Wireshark 
 
Now that we are familiar with nslookup and ipconfig, we’re ready to get down to some 
serious business. Let’s first capture the DNS packets that are generated by ordinary Web-
surfing activity. 
 

• Use ipconfig to empty the DNS cache in your host. 
• Open your browser and empty your browser cache. (With Internet Explorer, 

go to Tools menu and select Internet Options; then in the General tab select 
Delete Files.) 

• Open Wireshark and enter “ip.addr == your_IP_address” into the filter, where 
you obtain your_IP_address with ipconfig. This filter removes all packets that 
neither originate nor are destined to your host.  

• Start packet capture in Wireshark. 
• With your browser, visit the Web page: http://www.ietf.org  
• Stop packet capture.  

 
If you are unable to run Wireshark on a live network connection, you can download a 
packet trace file that was captured while following the steps above on one of the author’s 
computers2.  Answer the following questions. Whenever possible, when answering a 
question below, you should hand in a printout of the packet(s) within the trace that you 
used to answer the question asked.  Annotate the printout3 to explain your answer. To 
print a packet, use File->Print, choose Selected packet only, choose Packet summary 
line, and select the minimum amount of packet detail that you need to answer the 
question. 
 
 

4. Locate the DNS query and response messages. Are then sent over UDP or TCP?  
5. What is the destination port for the DNS query message? What is the source port 

of DNS response message? 
6. To what IP address is the DNS query message sent? Use ipconfig to determine the 

IP address of your local DNS server. Are these two IP addresses the same?  
7. Examine the DNS query message. What “Type” of DNS query is it? Does the 

query message contain any “answers”? 
8. Examine the DNS response message. How many “answers” are provided? What 

do each of these answers contain? 

                                                
2 Download the zip file http://gaia.cs.umass.edu/wireshark-labs/wireshark-traces.zipand extract the file dns-
ethereal-trace-1. The traces in this zip file were collected by Wireshark running on one of the author’s 
computers, while performing the steps indicated in the Wireshark lab. Once you have downloaded the 
trace, you can load it into Wireshark and view the trace using the File pull down menu, choosing Open, and 
then selecting the dns-ethereal-trace-1 trace file.   
3 What do we mean by “annotate”?  If you hand in a paper copy, please highlight where in the printout 
you’ve found the answer and add some text (preferably with a colored pen) noting what you found in what 
you ‘ve highlight.  If you hand in an electronic copy, it would be great if you could also highlight and 
annotate. 



9. Consider the subsequent TCP SYN packet sent by your host. Does the destination  
IP address of the SYN packet correspond to any of the IP addresses provided in 
the DNS response message? 

10. This web page contains images. Before retrieving each image, does your host 
issue new DNS queries?  

 
Now let’s play with nslookup4.  
 

• Start packet capture.  
• Do an nslookup on www.mit.edu 
• Stop packet capture.  

 
You should get a trace that looks something like the following:	
  

 
 
We see from the above screenshot that nslookup actually sent three DNS queries and 
received three DNS responses. For the purpose of this assignment, in answering the 
following questions, ignore the first two sets of queries/responses, as they are specific to 
nslookup and are not normally generated by standard Internet applications. You should 
instead focus on the last query and response messages. 
                                                
4 If you are unable to run Wireshark and capture a trace file, use the trace file dns-ethereal-trace-2 in the  
zip file http://gaia.cs.umass.edu/wireshark-labs/wireshark-traces.zip 



11. What is the destination port for the DNS query message? What is the source port 
of DNS response message? 

12. To what IP address is the DNS query message sent? Is this the IP address of your 
default local DNS server? 

13. Examine the DNS query message. What “Type” of DNS query is it? Does the 
query message contain any “answers”? 

14. Examine the DNS response message. How many “answers” are provided? What 
do each of these answers contain? 

15. Provide a screenshot. 
 
Now repeat the previous experiment, but instead issue the command: 
 
nslookup –type=NS mit.edu 
 
Answer the following questions5 : 
 

16. To what IP address is the DNS query message sent? Is this the IP address of your 
default local DNS server? 

17. Examine the DNS query message. What “Type” of DNS query is it? Does the 
query message contain any “answers”? 

18. Examine the DNS response message. What MIT nameservers does the response 
message provide? Does this response message also provide the IP addresses of the 
MIT namesers? 

19. Provide a screenshot. 
 
Now repeat the previous experiment, but instead issue the command: 
 
nslookup www.aiit.or.kr bitsy.mit.edu 
 
Answer the following questions6: 
 

20. To what IP address is the DNS query message sent? Is this the IP address of your 
default local DNS server? If not, what does the IP address correspond to? 

21. Examine the DNS query message. What “Type” of DNS query is it? Does the 
query message contain any “answers”? 

22. Examine the DNS response message. How many “answers” are provided? What 
does each of these answers contain? 

23. Provide a screenshot. 

                                                
5 If you are unable to run Wireshark and capture a trace file, use the trace file dns-ethereal-trace-3 in the  
zip file http://gaia.cs.umass.edu/wireshark-labs/wireshark-traces.zip 
6 If you are unable to run Wireshark and capture a trace file, use the trace file dns-ethereal-trace-4 in the  
zip file http://gaia.cs.umass.edu/wireshark-labs/wireshark-traces.zip 
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In this lab, we’ll investigate the behavior of the celebrated TCP protocol in detail.  We’ll 
do so by analyzing a trace of the TCP segments sent and received in transferring a 150KB 
file (containing the text of Lewis Carrol’s Alice’s Adventures in Wonderland) from your 
computer to a remote server. We’ll study TCP’s use of sequence and acknowledgement 
numbers for providing reliable data transfer; we’ll see TCP’s congestion control 
algorithm – slow start and congestion avoidance – in action; and we’ll look at TCP’s 
receiver-advertised flow control mechanism.  We’ll also briefly consider TCP connection 
setup and we’ll investigate the performance (throughput and round-trip time) of the TCP 
connection between your computer and the server. 
 
Before beginning this lab, you’ll probably want to review sections 3.5 and 3.7 in the 
text1. 
 
 
1. Capturing a bulk TCP transfer from your computer to a remote 
server 
 
Before beginning our exploration of TCP, we’ll need to use Wireshark to obtain a packet 
trace of the TCP transfer of a file from your computer to a remote server. You’ll do so by 
accessing a Web page that will allow you to enter the name of a file stored on your 
computer (which contains the ASCII text of Alice in Wonderland), and then transfer the 
file to a Web server using the HTTP POST method (see section 2.2.3 in the text).  We’re 
using the POST method rather than the GET method as we’d like to transfer a large 
amount of data from your computer to another computer. Of course, we’ll be running 
Wireshark during this time to obtain the trace of the TCP segments sent and received 
from your computer.  
 

                                                
1 References to figures and sections are for the 7th edition of our text, Computer Networks, A Top-down 
Approach, 7th ed., J.F. Kurose and K.W. Ross, Addison-Wesley/Pearson, 2016. 



Do the following: 
• Start up your web browser. Go the http://gaia.cs.umass.edu/wireshark-

labs/alice.txt and retrieve an ASCII copy of Alice in Wonderland. Store this file 
somewhere on your computer. 

• Next go to  http://gaia.cs.umass.edu/wireshark-labs/TCP-wireshark-file1.html. 
• You should see a screen that looks like: 

 

 
 
• Use the Browse button in this form to enter the name of the file (full path name) 

on your computer containing Alice in Wonderland (or do so manually). Don’t yet 
press the “Upload alice.txt file” button. 

• Now start up Wireshark and begin packet capture (Capture->Start) and then press 
OK on the Wireshark Packet Capture Options screen (we’ll not need to select any 
options here). 

• Returning to your browser, press the “Upload alice.txt file” button to upload the 
file to the gaia.cs.umass.edu server.  Once the file has been uploaded, a short 
congratulations message will be displayed in your browser window. 

• Stop Wireshark packet capture. Your Wireshark window should look similar to 
the window shown below. 

 
 



 
 
If you are unable to run Wireshark on a live network connection, you can download a 
packet trace file that was captured while following the steps above on one of the author’s 
computers2.  You may well find it valuable to download this trace even if you’ve 
captured your own trace and use it, as well as your own trace, when you explore the 
questions below. 
 
2.  A first look at the captured trace 
 
Before analyzing the behavior of the TCP connection in detail, let’s take a high level 
view of the trace.  

• First, filter the packets displayed in the Wireshark window by entering “tcp” 
(lowercase, no quotes, and don’t forget to press return after entering!) into the 
display filter specification window towards the top of the Wireshark window. 

 
What you should see is series of TCP and HTTP messages between your computer and 
gaia.cs.umass.edu.  You should see the initial three-way handshake containing a SYN 
message. You should see an HTTP POST message.  Depending on the version of 
                                                
2 Download the zip file http://gaia.cs.umass.edu/wireshark-labs/wireshark-traces.zip and extract the file tcp-
ethereal-trace-1. The traces in this zip file were collected by Wireshark running on one of the author’s 
computers, while performing the steps indicated in the Wireshark lab. Once you have downloaded the 
trace, you can load it into Wireshark and view the trace using the File pull down menu, choosing Open, and 
then selecting the tcp-ethereal-trace-1 trace file.   



Wireshark you are using, you might see a series of “HTTP Continuation” messages being 
sent from your computer to gaia.cs.umass.edu.  Recall from our discussion in the earlier 
HTTP Wireshark lab, that is no such thing as an HTTP Continuation message – this is 
Wireshark’s way of indicating that there are multiple TCP segments being used to carry a 
single HTTP message. In more recent versions of Wireshark, you’ll see “[TCP segment 
of a reassembled PDU]” in the Info column of the Wireshark display to indicate that this 
TCP segment contained data that belonged to an upper layer protocol message (in our 
case here, HTTP). You should also see TCP ACK segments being returned from 
gaia.cs.umass.edu to your computer. 
 
Answer the following questions, by opening the Wireshark captured packet file tcp-
ethereal-trace-1 in http://gaia.cs.umass.edu/wireshark-labs/wireshark-traces.zip (that is 
download the trace and open that trace in Wireshark; see footnote 2). Whenever possible, 
when answering a question you should hand in a printout of the packet(s) within the trace 
that you used to answer the question asked.  Annotate the printout3 to explain your 
answer. To print a packet, use File->Print, choose Selected packet only, choose Packet 
summary line, and select the minimum amount of packet detail that you need to answer 
the question. 

1. What is the IP address and TCP port number used by the client computer (source) 
that is transferring the file to gaia.cs.umass.edu?  To answer this question, it’s 
probably easiest to select an HTTP message and explore the details of the TCP 
packet used to carry this HTTP message, using the “details of the selected packet 
header window” (refer to Figure 2 in the “Getting Started with Wireshark” Lab if 
you’re uncertain about the Wireshark windows. 

2. What is the IP address of gaia.cs.umass.edu? On what port number is it sending 
and receiving TCP segments for this connection? 

 
If you have been able to create your own trace, answer the following question: 
 

3. What is the IP address and TCP port number used by your client computer 
(source) to transfer the file to gaia.cs.umass.edu?   

 
Since this lab is about TCP rather than HTTP, let’s change Wireshark’s “listing of 
captured packets” window so that it shows information about the TCP segments 
containing the HTTP messages, rather than about the HTTP messages. To have 
Wireshark do this, select Analyze->Enabled Protocols.  Then uncheck the HTTP box and 
select OK.  You should now see a Wireshark window that looks like: 
 

                                                
3 What do we mean by “annotate”?  If you hand in a paper copy, please highlight where in the printout 
you’ve found the answer and add some text (preferably with a colored pen) noting what you found in what 
you ‘ve highlight.  If you hand in an electronic copy, it would be great if you could also highlight and 
annotate. 



 
 
 
This is what we’re looking for - a series of TCP segments sent between your computer 
and gaia.cs.umass.edu.  We will use the packet trace that you have captured (and/or the 
packet trace tcp-ethereal-trace-1 in http://gaia.cs.umass.edu/wireshark-labs/wireshark-
traces.zip; see earlier footnote) to study TCP behavior in the rest of this lab.  
 
3. TCP Basics 
 
Answer the following questions for the TCP segments:   
 

4. What is the sequence number of the TCP SYN segment that is used to initiate the 
TCP connection between the client computer and gaia.cs.umass.edu?  What is it 
in the segment that identifies the segment as a SYN segment? 

5. What is the sequence number of the SYNACK segment sent by gaia.cs.umass.edu 
to the client computer in reply to the SYN?  What is the value of the 
Acknowledgement field in the SYNACK segment?  How did gaia.cs.umass.edu 
determine that value? What is it in the segment that identifies the segment as a 
SYNACK segment? 

6. What is the sequence number of the TCP segment containing the HTTP POST 
command?  Note that in order to find the POST command, you’ll need to dig into 
the packet content field at the bottom of the Wireshark window, looking for a 
segment with a “POST” within its DATA field. 

7. Consider the TCP segment containing the HTTP POST as the first segment in the 
TCP connection. What are the sequence numbers of the first six segments in the 



TCP connection (including the segment containing the HTTP POST)?  At what 
time was each segment sent?  When was the ACK for each segment received?  
Given the difference between when each TCP segment was sent, and when its 
acknowledgement was received, what is the RTT value for each of the six 
segments?  What is the EstimatedRTT value (see Section 3.5.3, page 242 in 
text) after the receipt of each ACK?  Assume that the value of the 
EstimatedRTT is equal to the measured RTT for the first segment, and then is 
computed using the EstimatedRTT equation on page 242 for all subsequent 
segments. 

Note: Wireshark has a nice feature that allows you to plot the RTT for 
each of the TCP segments sent.  Select a TCP segment in the “listing of 
captured packets” window that is being sent from the client to the 
gaia.cs.umass.edu server.  Then select: Statistics->TCP Stream Graph-
>Round Trip Time Graph. 

8. What is the length of each of the first six TCP segments?4 
9. What is the minimum amount of available buffer space advertised at the received 

for the entire trace?  Does the lack of receiver buffer space ever throttle the 
sender? 

10. Are there any retransmitted segments in the trace file? What did you check for (in 
the trace) in order to answer this question? 

11. How much data does the receiver typically acknowledge in an ACK?  Can you 
identify cases where the receiver is ACKing every other received segment (see 
Table 3.2 on page 250 in the text). 

12. What is the throughput (bytes transferred per unit time) for the TCP connection?  
Explain how you calculated this value. 

 
 

                                                
4 The TCP segments in the tcp-ethereal-trace-1 trace file are all less that 1460 bytes.  This is because the 
computer on which the trace was gathered has an Ethernet card that limits the length of the maximum IP 
packet to 1500 bytes (40 bytes of TCP/IP header data and 1460 bytes of TCP payload).  This 1500 byte 
value is the standard maximum length allowed by Ethernet.  If your trace indicates a TCP length greater 
than 1500 bytes, and your computer is using an Ethernet connection, then Wireshark is reporting the wrong 
TCP segment length; it will likely also show only one large TCP segment rather than multiple smaller 
segments.  Your computer is indeed probably sending multiple smaller segments, as indicated by the ACKs 
it receives.  This inconsistency in reported segment lengths is due to the interaction between the Ethernet 
driver and the Wireshark software.  We recommend that if you have this inconsistency, that you perform 
this lab using the provided trace file. 



4. TCP congestion control in action  
 
Let’s now examine the amount of data sent per unit time from the client to the server.  
Rather than (tediously!) calculating this from the raw data in the Wireshark window, 
we’ll use one of Wireshark’s TCP graphing utilities - Time-Sequence-Graph(Stevens) - to 
plot out data. 

• Select a TCP segment in the Wireshark’s “listing of captured-packets” window. 
Then select the menu : Statistics->TCP Stream Graph-> Time-Sequence-
Graph(Stevens).  You should see a plot that looks similar to the following plot, 
which was created from the captured packets in the packet trace tcp-ethereal-
trace-1 in http://gaia.cs.umass.edu/wireshark-labs/wireshark-traces.zip (see earlier 
footnote ): 

 

 
 

Here, each dot represents a TCP segment sent, plotting the sequence number of 
the segment versus the time at which it was sent. Note that a set of dots stacked 
above each other represents a series of packets that were sent back-to-back by the 
sender. 

 



Answer the following questions for the TCP segments the packet trace tcp-ethereal-
trace-1 in http://gaia.cs.umass.edu/wireshark-labs/wireshark-traces.zip 

13. Use the Time-Sequence-Graph(Stevens) plotting tool to view the sequence 
number versus time plot of segments being sent from the client to the 
gaia.cs.umass.edu server.  Can you identify where TCP’s slowstart phase begins 
and ends, and where congestion avoidance takes over?  Comment on ways in 
which the measured data differs from the idealized behavior of TCP that we’ve 
studied in the text. 

14. Answer each of two questions above for the trace that you have gathered when 
you transferred a file from your computer to gaia.cs.umass.edu 
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In this lab, we’ll investigate the IP protocol, focusing on the IP datagram. We’ll do so by 
analyzing a trace of IP datagrams sent and received by an execution of the traceroute 
program (the traceroute program itself is explored in more detail in the Wireshark 
ICMP lab). We’ll investigate the various fields in the IP datagram, and study IP 
fragmentation in detail.  
 
Before beginning this lab, you’ll probably want to review sections 1.4.3 in the text1 and 
section 3.4 of RFC 2151 [ftp://ftp.rfc-editor.org/in-notes/rfc2151.txt] to update yourself 
on the operation of the traceroute program.  You’ll also want to read Section 4.3 in 
the text, and probably also have RFC 791 [ftp://ftp.rfc-editor.org/in-notes/rfc791.txt] on 
hand as well, for a discussion of the IP protocol. 
 
 
1. Capturing packets from an execution of traceroute 
 
In order to generate a trace of IP datagrams for this lab, we’ll use the traceroute 
program to send datagrams of different sizes towards some destination, X.  Recall that 
traceroute operates by first sending one or more datagrams with the time-to-live 
(TTL) field in the IP header set to 1; it then sends a series of one or more datagrams 
towards the same destination with a TTL value of 2; it then sends a series of datagrams 
towards the same destination with a TTL value of 3; and so on.  Recall that a router must 
decrement the TTL in each received datagram by 1 (actually, RFC 791 says that the 
router must decrement the TTL by at least one). If the TTL reaches 0, the router returns 
an ICMP message (type 11 – TTL-exceeded) to the sending host. As a result of this 
behavior, a datagram with a TTL of 1 (sent by the host executing traceroute) will 
cause the router one hop away from the sender to send an ICMP TTL-exceeded message 
back to the sender; the datagram sent with a TTL of 2 will cause the router two hops 

                                                
1 References to figures and sections are for the 7th edition of our text, Computer Networks, A Top-down 
Approach, 7th ed., J.F. Kurose and K.W. Ross, Addison-Wesley/Pearson, 2016. 



away to send an ICMP message back to the sender; the datagram sent with a TTL of 3 
will cause the router three hops away to send an ICMP message back to the sender; and 
so on.  In this manner, the host executing traceroute can learn the identities of the 
routers between itself and destination X by looking at the source IP addresses in the 
datagrams containing the ICMP TTL-exceeded messages. 
 
We’ll want to run traceroute and have it send datagrams of various lengths. 
 

• Windows.  The tracert program (used for our ICMP Wireshark lab) provided 
with Windows does not allow one to change the size of the ICMP echo request 
(ping) message sent by the tracert program. A nicer Windows traceroute 
program is pingplotter, available both in free version and shareware versions at 
http://www.pingplotter.com. Download and install pingplotter, and test it out by 
performing a few traceroutes to your favorite sites.  The size of the ICMP echo 
request message can be explicitly set in pingplotter by selecting the menu item 
Edit-> Options->Packet Options and then filling in the Packet Size field.  The 
default packet size is 56 bytes.  Once pingplotter has sent a series of packets with 
the increasing TTL values, it restarts the sending process again with a TTL of 1, 
after waiting Trace Interval amount of time. The value of Trace Interval and the 
number of intervals can be explicitly set in pingplotter. 

• Linux/Unix/MacOS.  With the Unix/MacOS traceroute command, the size 
of the UDP datagram sent towards the destination can be explicitly set by 
indicating the number of bytes in the datagram; this value is entered in the 
traceroute command line immediately after the name or address of the  
destination.  For example, to send traceroute datagrams of 2000 bytes 
towards gaia.cs.umass.edu, the command would be: 

%traceroute gaia.cs.umass.edu 2000 
 
Do the following: 

• Start up Wireshark and begin packet capture (Capture->Start) and then press OK 
on the Wireshark Packet Capture Options screen (we’ll not need to select any 
options here). 

• If you are using a Windows platform, start up pingplotter and enter the name of a 
target destination in the “Address to Trace Window.”  Enter 3 in the “# of times to 
Trace” field, so you don’t gather too much data.  Select the menu item Edit-
>Advanced Options->Packet Options and enter a value of 56 in the Packet Size 
field and then press OK.  Then press the Trace button.  You should see a 
pingplotter window that looks something like this: 

 



 
 

Next, send a set of datagrams with a longer length, by selecting Edit->Advanced 
Options->Packet Options and enter a value of 2000 in the Packet Size field and 
then press OK. Then press the Resume button. 
 
Finally, send a set of datagrams with a longer length, by selecting Edit-
>Advanced Options->Packet Options and enter a value of 3500 in the Packet Size 
field and then press OK.  Then press the Resume button. 
 
Stop Wireshark tracing. 

 
• If you are using a Unix or Mac platform, enter three traceroute commands, 

one with a length of 56 bytes, one with a length of 2000 bytes, and one with a 
length of 3500 bytes. 

 
Stop Wireshark tracing. 

 
 
If you are unable to run Wireshark on a live network connection, you can download a 
packet trace file that was captured while following the steps above on one of the author’s 
Windows computers2.  You may well find it valuable to download this trace even if 
you’ve captured your own trace and use it, as well as your own trace, when you explore 
the questions below. 
 

                                                
2 Download the zip file http://gaia.cs.umass.edu/wireshark-labs/wireshark-traces.zip and extract the file ip-
ethereal-trace-1. The traces in this zip file were collected by Wireshark running on one of the author’s 
computers, while performing the steps indicated in the Wireshark lab. Once you have downloaded the 
trace, you can load it into Wireshark and view the trace using the File pull down menu, choosing Open, and 
then selecting the ip-ethereal-trace-1 trace file.   



2.  A look at the captured trace 
 
In your trace, you should be able to see the series of ICMP Echo Request (in the case of 
Windows machine) or the UDP segment (in the case of Unix) sent by your computer and 
the ICMP TTL-exceeded messages returned to your computer by the intermediate 
routers.  In the questions below, we’ll assume you are using a Windows machine; the 
corresponding questions for the case of a Unix machine should be clear. Whenever 
possible, when answering a question below you should hand in a printout of the packet(s) 
within the trace that you used to answer the question asked.  When you hand in your 
assignment, annotate the output so that it’s clear where in the output you’re getting the 
information for your answer (e.g., for our classes, we ask that students markup paper 
copies with a pen, or annotate electronic copies with text in a colored font).To print a 
packet, use File->Print, choose Selected packet only, choose Packet summary line, and 
select the minimum amount of packet detail that you need to answer the question. 
 

1. Select the first ICMP Echo Request message sent by your computer, and expand 
the Internet Protocol part of the packet in the packet details window.   
 

 
What is the IP address of your computer? 

2. Within the IP packet header, what is the value in the upper layer protocol field? 
3. How many bytes are in the IP header? How many bytes are in the payload of the 

IP datagram?  Explain how you determined the number of payload bytes. 
4. Has this IP datagram been fragmented?  Explain how you determined whether or 

not the datagram has been fragmented. 
 



Next, sort the traced packets according to IP source address by clicking on the Source 
column header; a small downward pointing arrow should appear next to the word Source.  
If the arrow points up, click on the Source column header again.  Select the first ICMP 
Echo Request message sent by your computer, and expand the Internet Protocol portion 
in the “details of selected packet header” window.  In the “listing of captured packets” 
window, you should see all of the subsequent ICMP messages (perhaps with additional 
interspersed packets sent by other protocols running on your computer) below this first 
ICMP.  Use the down arrow to move through the ICMP messages sent by your computer.   
 

5. Which fields in the IP datagram always change from one datagram to the next 
within this series of ICMP messages sent by your computer? 

6. Which fields stay constant?  Which of the fields must stay constant? Which fields 
must change?  Why? 

7. Describe the pattern you see in the values in the Identification field of the IP 
datagram 

 
Next (with the packets still sorted by source address) find the series of ICMP TTL-
exceeded replies sent to your computer by the nearest (first hop) router. 
 

8. What is the value in the Identification field and the TTL field? 
9. Do these values remain unchanged for all of the ICMP TTL-exceeded replies sent 

to your computer by the nearest (first hop) router?  Why? 
 
Fragmentation 
 
Sort the packet listing according to time again by clicking on the Time column. 
 

10. Find the first ICMP Echo Request message that was sent by your computer after 
you changed the Packet Size in pingplotter to be 2000. Has that message been 
fragmented across more than one IP datagram?  [Note: if you find your packet has 
not been fragmented, you should download the zip file 
http://gaia.cs.umass.edu/wireshark-labs/wireshark-traces.zip and extract the ip-
ethereal-trace-1packet trace. If your computer has an Ethernet interface, a packet 
size of 2000 should cause fragmentation.3] 

11. Print out the first fragment of the fragmented IP datagram. What information in 
the IP header indicates that the datagram been fragmented?  What information in 
the IP header indicates whether this is the first fragment versus a latter fragment?  
How long is this IP datagram? 

                                                
3 The packets in the ip-ethereal-trace-1 trace file in  http://gaia.cs.umass.edu/wireshark-labs/wireshark-
traces.zip are all less that 1500 bytes.  This is because the computer on which the trace was gathered has an 
Ethernet card that limits the length of the maximum IP packet to 1500 bytes (40 bytes of TCP/IP header 
data and 1460 bytes of upper-layer protocol payload).  This 1500 byte value is the standard maximum 
length allowed by Ethernet.  If your trace indicates a datagram longer 1500 bytes, and your computer is 
using an Ethernet connection, then Wireshark is reporting the wrong IP datagram length; it will likely also 
show only one large IP datagram rather than multiple smaller datagrams..  This inconsistency in reported 
lengths is due to the interaction between the Ethernet driver and the Wireshark software.  We recommend 
that if you have this inconsistency, that you perform this lab using the ip-ethereal-trace-1 trace file. 



12. Print out the second fragment of the fragmented IP datagram. What information in 
the IP header indicates that this is not the first datagram fragment?  Are the more 
fragments?  How can you tell? 

13. What fields change in the IP header between the first and second fragment? 
 
Now find the first ICMP Echo Request message that was sent by your computer after you 
changed the Packet Size in pingplotter to be 3500. 
 

14. How many fragments were created from the original datagram?  
15. What fields change in the IP header among the fragments? 
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In this lab, we’ll investigate the Ethernet protocol and the ARP protocol.  Before 
beginning this lab, you’ll probably want to review sections 6.4.1 (Link-layer addressing 
and ARP) and 6.4.2 (Ethernet) in the text1. RFC 826 (ftp://ftp.rfc-editor.org/in-
notes/std/std37.txt) contains the gory details of the ARP protocol, which is used by an IP 
device to determine the IP address of a remote interface whose Ethernet address is 
known. 
 
1. Capturing and analyzing Ethernet frames 
 
Let’s begin by capturing a set of Ethernet frames to study.  Do the following2: 
 

• First, make sure your browser’s cache is empty. To do this under Mozilla  Firefox 
V3, select Tools->Clear Recent History and check the box for Cache. For Internet 
Explorer, select Tools->Internet Options->Delete Files.  Start up the Wireshark 
packet sniffer 

• Enter the following URL into your browser 
http://gaia.cs.umass.edu/wireshark-labs/HTTP-ethereal-lab-file3.html 
Your browser should display the rather lengthy US Bill of Rights. 

                                                
1 References to figures and sections are for the 7th edition of our text, Computer Networks, A Top-down 
Approach, 7th ed., J.F. Kurose and K.W. Ross, Addison-Wesley/Pearson, 2016. 
2 If you are unable to run Wireshark live on a computer, you can download the zip file 
http://gaia.cs.umass.edu/wireshark-labs/wireshark-traces.zip and extract the file ethernet--ethereal-trace-1. 
The traces in this zip file were collected by Wireshark running on one of the author’s computers, while 
performing the steps indicated in the Wireshark lab. Once you have downloaded the trace, you can load it 
into Wireshark and view the trace using the File pull down menu, choosing Open, and then selecting the 
ethernet-ethereal-trace-1 trace file.  You can then use this trace file to answer the questions below. 



• Stop Wireshark packet capture. First, find the packet numbers (the leftmost 
column in the upper Wireshark window) of the HTTP GET message that was sent 
from your computer to gaia.cs.umass.edu, as well as the beginning of the HTTP 
response message sent to your computer by gaia.cs.umass.edu.  You should see a 
screen that looks something like this (where packet 4 in the screen shot below 
contains the HTTP GET message) 

 

 
 



• Since this lab is about Ethernet and ARP, we’re not interested in IP or higher-
layer protocols. So let’s change Wireshark’s “listing of captured packets” window 
so that it shows information only about protocols below IP. To have Wireshark do 
this, select Analyze->Enabled Protocols.  Then uncheck the IP box and select OK.  
You should now see an Wireshark window that looks like: 

 

 
 
In order to answer the following questions, you’ll need to look into the packet details and 
packet contents windows (the middle and lower display windows in Wireshark). 
 
Select the Ethernet frame containing the HTTP GET message. (Recall that the HTTP 
GET message is carried inside of a TCP segment, which is carried inside of an IP 
datagram, which is carried inside of an Ethernet frame; reread section 1.5.2 in the text if 
you find this encapsulation a bit confusing). Expand the Ethernet II information in the 
packet details window.  Note that the contents of the Ethernet frame (header as well as 
payload) are displayed in the packet contents window. 



 
Answer the following questions, based on the contents of the Ethernet frame containing 
the HTTP GET message. Whenever possible, when answering a question you should 
hand in a printout of the packet(s) within the trace that you used to answer the question 
asked.  Annotate the printout3  to explain your answer. To print a packet, use File->Print, 
choose Selected packet only, choose Packet summary line, and select the minimum 
amount of packet detail that you need to answer the question. 
 

1. What is the 48-bit Ethernet address of your computer? 
2. What is the 48-bit destination address in the Ethernet frame?  Is this the Ethernet 

address of gaia.cs.umass.edu? (Hint: the answer is no).  What device has this as its 
Ethernet address? [Note: this is an important question, and one that students 
sometimes get wrong.  Re-read pages 468-469 in the text and make sure you 
understand the answer here.] 

3. Give the hexadecimal value for the two-byte Frame type field.  What upper layer 
protocol does this correspond to? 

4. How many bytes from the very start of the Ethernet frame does the ASCII “G” in 
“GET” appear in the Ethernet frame? 

 
 
Next, answer the following questions, based on the contents of the Ethernet frame 
containing the first byte of the HTTP response message. 

5. What is the value of the Ethernet source address?  Is this the address of your 
computer, or of gaia.cs.umass.edu (Hint: the answer is no).   What device has this 
as its Ethernet address? 

6. What is the destination address in the Ethernet frame?  Is this the Ethernet address 
of your computer?  

7. Give the hexadecimal value for the two-byte Frame type field. What upper layer 
protocol does this correspond to? 

8. How many bytes from the very start of the Ethernet frame does the ASCII “O” in 
“OK” (i.e., the HTTP response code) appear in the Ethernet frame? 

 

                                                
3 What do we mean by “annotate”?  If you hand in a paper copy, please highlight where in the printout 
you’ve found the answer and add some text (preferably with a colored pen) noting what you found in what 
you ‘ve highlight.  If you hand in an electronic copy, it would be great if you could also highlight and 
annotate. 



2. The Address Resolution Protocol 
 
In this section, we’ll observe the ARP protocol in action.  We strongly recommend that 
you re-read section 6.4.1 in the text before proceeding. 
 
ARP Caching 
 
Recall that the ARP protocol typically maintains a cache of IP-to-Ethernet address 
translation pairs on your comnputer  The arp command (in both MSDOS and 
Linux/Unix) is used to view and manipulate the contents of this cache. Since the arp 
command and the ARP protocol have the same name, it’s understandably easy to confuse 
them. But keep in mind that they are different - the arp command is used to view and 
manipulate the ARP cache contents, while the ARP protocol defines the format and 
meaning of the messages sent and received, and defines the actions taken on message 
transmission and receipt. 
 
Let’s take a look at the contents of the ARP cache on your computer: 
 

• MS-DOS.  The arp command is in c:\windows\system32, so type either “arp” or 
“c:\windows\system32\arp” in the MS-DOS command line (without quotation 
marks). 

• Linux/Unix/MacOS. The executable for the  arp command can be in various 
places.  Popular locations are /sbin/arp (for linux) and /usr/etc/arp (for some Unix 
variants). 

 
The Windows  arp command with no arguments will display the contents of the ARP 
cache on your computer.  Run the arp command. 
 

9. Write down the contents of your computer’s ARP cache.  What is the meaning of 
each column value? 

 
In order to observe your computer sending and receiving ARP messages, we’ll need to 
clear the ARP cache, since otherwise your computer is likely to find a needed IP-Ethernet 
address translation pair in its cache and consequently not need to send out an ARP 
message. 
 

• MS-DOS.  The MS-DOS arp –d * command will clear your ARP cache.  The –d 
flag indicates a deletion operation, and the * is the wildcard that says to delete all 
table entries. 

• Linux/Unix/MacOS. The arp –d * will clear your ARP cache.  In order to run 
this command you’ll need root privileges.  If you don’t have root privileges and 
can’t run Wireshark on a Windows machine, you can skip the trace collection part 
of this lab and just use the trace discussed in the earlier footnote. 

 



Observing ARP in action 
 
Do the following4: 
 

• Clear your ARP cache, as described above. 
• Next, make sure your browser’s cache is empty. To do this under Mozilla  Firefox 

V3, select Tools->Clear Recent History and check the box for Cache. For Internet 
Explorer, select Tools->Internet Options->Delete Files. 

• Start up the Wireshark packet sniffer 
• Enter the following URL into your browser 

http://gaia.cs.umass.edu/wireshark-labs/HTTP-wireshark-lab-file3.html 
Your browser should again display the rather lengthy US Bill of Rights. 

• Stop Wireshark packet capture. Again, we’re not interested in IP or higher-layer 
protocols, so change Wireshark’s “listing of captured packets” window so that it 
shows information only about protocols below IP. To have Wireshark do this, 
select Analyze->Enabled Protocols.  Then uncheck the IP box and select OK.  
You should now see an Wireshark window that looks like: 

 

                                                
4 The ethernet-ethereal-trace-1 trace file in http://gaia.cs.umass.edu/wireshark-labs/wireshark-traces.zip 
was created using the steps below (in particular after the ARP cache had been flushed).   
 



 
 

In the example above, the first two frames in the trace contain ARP messages (as does the 
6th message).  The screen shot above corresponds to the trace referenced in footnote 1. 

Answer the following questions: 

10. What are the hexadecimal values for the source and destination addresses in the 
Ethernet frame containing the ARP request message? 

11. Give the hexadecimal value for the two-byte Ethernet Frame type field.  What 
upper layer protocol does this correspond to? 

12. Download the ARP specification from 
 ftp://ftp.rfc-editor.org/in-notes/std/std37.txt. A readable, detailed discussion of 
ARP is also at http://www.erg.abdn.ac.uk/users/gorry/course/inet-pages/arp.html.  

a) How many bytes from the very beginning of the Ethernet frame does the 
ARP opcode field begin?   

b) What is the value of the opcode field within the ARP-payload part of the 
Ethernet frame in which an ARP request is made? 

c) Does the ARP message contain the IP address of the sender? 



d) Where in the ARP request does the “question” appear – the Ethernet 
address of the machine whose corresponding IP address is being queried? 

13. Now find the ARP reply that was sent in response to the ARP request.  
a) How many bytes from the very beginning of the Ethernet frame does the 

ARP opcode field begin?   
b) What is the value of the opcode field within the ARP-payload part of the 

Ethernet frame in which an ARP response is made? 
c) Where in the ARP message does the “answer” to the earlier ARP request 

appear – the IP address of the machine having the Ethernet address whose 
corresponding IP address is being queried? 

14. What are the hexadecimal values for the source and destination addresses in the 
Ethernet frame containing the ARP reply message? 

15. Open the ethernet-ethereal-trace-1 trace file in 
http://gaia.cs.umass.edu/wireshark-labs/wireshark-traces.zip. The first and second 
ARP packets in this trace correspond to an ARP request sent by the computer 
running Wireshark, and the ARP reply sent to the computer running Wireshark by 
the computer with the ARP-requested Ethernet address.  But there is yet another 
computer on this network, as indicated by packet 6 – another ARP request.  Why 
is there no ARP reply (sent in response to the ARP request in packet 6) in the 
packet trace? 

Extra Credit 

EX-1. The arp command: 

arp -s InetAddr EtherAddr   

allows you to manually add an entry to the ARP cache that resolves the IP address 
InetAddr to the physical address EtherAddr. What would happen if, when you 
manually added an entry, you entered the correct IP address, but the wrong 
Ethernet address for that remote interface?  

EX-2.  What is the default amount of time that an entry remains in your ARP cache 
before being removed.  You can determine this empirically (by monitoring the 
cache contents) or by looking this up in your operation system documentation.  
Indicate how/where you determined this value.  
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